1. 首页
  2. 宝塔面板

宝塔面板wordpress“知更鸟”主题升级到php7.3,出现“警告错误提示”的解决办法

阿里云服务器优惠

最近,将网站运行的硬件进行了升级,从虚拟主机换成了vps,同时,用上最新的宝塔面板(基于centos7的6.9版本),php主要是用7.3版本,网上资料说,wordpress完美支持php7.0及以上版本,那么现阶段选择php7.3是可以承前启后的。

附为什么要选择php7,因为快;为什么选择php7.3,因为其稳定。

一通wordpress搬家操作。域名解析更换且成功后,浏览网站,出现这么一大串:

constant gallerytag – assumed ‘gallerytag’ (this will throw an Error in a future version of PHP) in……
constant videotag – assumed ‘videotag’ (this will throw an Error in a future version of PHP) in……
constant taotag – assumed ‘taotag’ (this will throw an Error in a future version of PHP) in……
constant filtersa – assumed ‘filtersa’ (this will throw an Error in a future version of PHP) in constant filtersb – assumed ‘filtersb’ (this will throw an Error in a future version of PHP) in……

……好多好多,不忍描述。然后下面是网站正常的样子。

以上这些错误大概意思是“使用了未定义的常量gallerytag、videotag、taotag、filtersa、filtersb,这将在未来的PHP版本中引发错误“;

我去,不是说wordpress完美支持php7么?怎么会这样,细一思考,这其实不怪wordpress,而是用的是“知更鸟”主题,这个主题有很多字段模型,如上面的gallerytag、videotag等,这都是主题附带的。

那解决方法有两种:

一、升级主题,这个不太现实。

二、只是报了”Warning警告“,我能不能不让这些错误信息显示?

看来只需要关闭”PHP错误提示“就行了。宝塔面板中操作如下:

进入php管理,点“配置修改”,设置display_errors为关闭,然后保存,重启一下服务。

image.png

就这么简单。

如果不是在宝塔面板,那就要深入腹地,修改php.ini文件。

1、打开 php.ini

2、设置 error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT

3、设置 display_errors = Off

其实两个方法,只是方式不同,改的都是同一个东西。

原文地址:http://tencent.yundashi168.com/560.html

原创文章,作者:admin,如若转载,请注明出处:http://tencent.yundashi168.com/560.html

发表评论

邮箱地址不会被公开。 必填项已用*标注

联系我们

400-800-8888

在线咨询:点击这里给我发消息

邮件:admin@example.com

工作时间:周一至周五,9:30-18:30,节假日休息

QR code

2020年阿里云618大促活动(有香港主机)

1核/2G/1M---91元1年,三年275元;
2核/4G/1M---320元1年,三年960元;
2核/8G/1M---416元1年,三年1093元;
4核/8G/1M---465元1年,三年1396元;
1核2G(香港,不用备案)---249元1年,三年888元;点击直达
还有还有4核8G6M、8核16G10M配置,价格很低很低!

注意:这个价,只有新用户才能看到;老用户借用家人身份重新注册,这个价格重新注册也不亏!

我知道了